Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jan 11, 2025 - 16:30 UTC
Scheduled
We will be undergoing scheduled maintenance during this time.
Posted Jan 11, 2025 - 16:29 UTC
This scheduled maintenance affected: Persefoni Pro (Persefoni Pro Application, Persefoni Pro API, Persefoni Pro Third Party Integrations, Persefoni Pro Knowledge Base).