Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 19, 2025 - 15:00 UTC
Scheduled
Persefoni Advanced and Pro CMAP platform Disaster Recovery Test
Posted Jul 19, 2025 - 14:33 UTC
This scheduled maintenance affected: Persefoni Advanced (Persefoni Advanced Application, Persefoni Advanced API, Persefoni Advanced Third Party Integrations) and Persefoni Pro (Persefoni Pro Application, Persefoni Pro API, Persefoni Pro Third Party Integrations).